Saturday, November 20, 2010
VOIP with H323 GW and GK and SKINNY too within INTRANET
GateKeeper is GK in network, GW are R6 and R7 acting as H323 and Skinny GWs.
In this I designed a network which supports Voip only network and I leveraged my network with GK and GWfor voip support . Where GK handles two intranet sites(zones). GWs having both telephony and H323 GW functionality configured.
Routing Protocol I used here is OSPF for routing the call and load balancing purpose also.
C1 and C2 are two sites. I used cisco communicator in my scenario at C1 and C2 sites.
Here is the configuration details of routers (I am configuration of GK and GWs only. Routing protocol is your choice which one you want to implement).
Note: Loopback is used as source interface for GK and GW service listening. I highlighted main GW and GK configuration in effected routers.
GK configuration:
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname GK
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
resource policy
!
ip cef
!
interface Loopback0
ip address 10.10.10.10 255.255.255.255
ip ospf 1 area 0
!
interface FastEthernet0/0
ip address 172.16.1.1 255.255.255.252
ip ospf 1 area 0
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 172.16.1.5 255.255.255.252
ip ospf 1 area 0
duplex auto
speed auto
!
router ospf 1
log-adjacency-changes
!
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
!
!
!
!
!
!
control-plane
!
!
gatekeeper
zone local zone1 khanrahil.com 10.10.10.10 enable-intrazone
zone local zone2 khanrahil.com enable-intrazone
zone prefix zone1 1.
zone prefix zone2 2.
bandwidth total zone zone1 1200
bandwidth total zone zone2 1200
bandwidth session default 128
bandwidth session zone zone1 128
bandwidth session zone zone2 128
bandwidth remote 1500
bandwidth check-destination
no shutdown
!
!
line con 0
exec-timeout 0 0
logging synchronous
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end
R6 Configuration:
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R6
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
!
!
interface Loopback0
ip address 30.30.30.30 255.255.255.255
ip ospf 1 area 2
h323-gateway voip interface
h323-gateway voip id zone1 ipaddr 10.10.10.10 1719
h323-gateway voip h323-id R6
h323-gateway voip bind srcaddr 30.30.30.30
!
interface FastEthernet0/0
ip address 10.1.2.22 255.255.255.252
ip ospf 1 area 2
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 10.1.2.26 255.255.255.252
ip ospf 1 area 2
duplex auto
speed auto
!
interface FastEthernet1/0
ip address 192.168.1.10 255.255.255.0
duplex auto
speed auto
!
!
router ospf 1
router-id 6.6.6.6
log-adjacency-changes
summary-address 0.0.0.0 0.0.0.0 not-advertise
default-information originate
!
ip http server
no ip http secure-server
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
dial-peer voice 20 voip
destination-pattern ..
session target ras
codec g711alaw
!
gateway
timer receive-rtp 1200
!
!
!
telephony-service
max-ephones 1
max-dn 1
ip source-address 192.168.1.10 port 2000
auto assign 1 to 1
create cnf-files version-stamp Jan 01 2002 00:00:00
max-conferences 8 gain -6
transfer-system full-consult
!
!
ephone-dn 1
number 10
!
!
ephone 1
mac-address 001C.C088.0461
type CIPC
button 1:1
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
R7 Configuration:
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R7
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
memory-size iomem 5
!
!
ip cef
no ip domain lookup
!
!
!
interface Loopback0
ip address 20.20.20.20 255.255.255.255
ip ospf 1 area 1
h323-gateway voip interface
h323-gateway voip id zone2 ipaddr 10.10.10.10 1719
h323-gateway voip h323-id R7
h323-gateway voip bind srcaddr 20.20.20.20
!
interface FastEthernet0/0
ip address 192.168.2.1 255.255.255.0
ip ospf 1 area 1
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial1/0
ip address 10.1.1.2 255.255.255.252
ip ospf 1 area 1
serial restart-delay 0
!
interface Serial1/1
ip address 10.1.1.14 255.255.255.252
ip ospf 1 area 1
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
!
router ospf 1
router-id 7.7.7.7
log-adjacency-changes
passive-interface FastEthernet0/0
!
ip http server
no ip http secure-server
ip forward-protocol nd
!
!
!
!
!
!
!
control-plane
!
!
dial-peer voice 10 voip
destination-pattern ..
session target ras
codec g711alaw
!
gateway
timer receive-rtp 1200
!
!
!
telephony-service
max-ephones 1
max-dn 1
ip source-address 192.168.2.1 port 2000
auto assign 1 to 1
create cnf-files version-stamp Jan 01 2002 00:00:00
max-conferences 8 gain -6
transfer-system full-consult
!
!
ephone-dn 1
number 20
!
!
ephone 1
mac-address 000C.29C0.A452
type CIPC
button 1:1
!
!
!
line con 0
exec-timeout 0 0
logging synchronous
line aux 0
line vty 0 4
login
!
!
end
Subscribe to:
Post Comments (Atom)
No comments:
Post a Comment